Rhino 8 The Interface Lesson01

Rhino 8 Lesson01 — The Interface
Start Rhino.

Select a template.

Perspective view

Solid > Box > Corner to Corner, Height

ﬂ Untitled - Rhino 8 Educational Lab License
File Edit View Curve Surface SubD Solid Mesh Drafting Transform Tools Analyze Render Window Help

. Standard CPlanes SetView Displ Box > Corner to Corner, Height S
: D = E‘ S g’ X @ tl "“ Sphere > Diagonal IEE
Top |v Cylinder 3 Points, Height
[y = . J\,‘ Cone Vertical Base
;jz. ®‘ (E; Truncated Cone Center of Base, Corner, Height
P~ —a oy Pyramid

Viewports, active view, click view tab to activate view without deselecting objects.
Window title.

Window > Window Layouts > Default window layout

Menu by functions
Curve > Line > Single Line

Curve > Line > Line Segments, Press ENTER to end not ESC.

ﬂ Untitled - Rhino 8 Educational Lab License
File Edit View Curve Surface SubD Solid Mesh Drafting Transform Tools Analyze

. Standard CP Point Object » Viewport Layout Visibility Transform
: - =0 ey ol
De@E ronoou > 51O B 5 -, @, %,
= | Line > Single Line
R oo A ' i
P Polyline > Line Segments
>
®‘(B; Rl Perpendicular from Curve
>
D. E‘ @. Rolvacy Perpendicular to 2 Curves
- ¥
D-j, ag % Rz Tangent from Curve
' A C)‘
i >
g‘@‘q Circle Tangent to 2 Curves
a el] u Arc > Tangent, Perpendicular

Finishing a command => Selection tool
Select Objects, Delete, or Del on keyboard, or Edit > Delete
To deselect, click a blank area, or press ESC once => Control lines, twice to deselect.

Transform > Move, to move the whole object or just control lines
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You can move using multiple viewports to select objects, specify base point, and displacement.

Edit > Undo or CTRL+Z

The Command window
Float, double-click
Dock below viewports

Size

Tools > Options — Appearance: Text size, Uncheck Command prompt, etc.

E Rhino Options

> Annctation Styles Language used for display
Document User Text English (United States)
Grid
Hatch
Linetypes Command prompt
Location Segoe Ul
Mesh Text size:

MNotes
Background:
» Render
Text color:
Units
Web Browser Hover color:

Rhino Options Echo prompts to history
Advanced Autocomplete commands
Alerter Use fuzzy autocomplete
Aliases

» Appearance L .

.pp Direction arrow icon
File Explorer
> Files Shaft size:
General Arrowhead size:
Idle Processar
Keyboard Show the following items
Licenses e

Line command, ENTER, SPACEBAR, Right-click

Logout
Login
Loft
OSnap LockViewport
= ¥ LockSwap
| End Lock
Mear LoadScript
' Paint List
Mid Linetypes
Cen LinetypeDisplay
Int LineThroughPt
Perp Lines
Tan LinearLight
Quad Line
Knot LimitReferenceModel
Vertex Lights
Project Libraries
Length
Disable LegacyRecordAnimation
Leader
Layouts
LayoutProperties
Layout
tayer?mil\«‘lanager bnt Righ
. ayerBoo
End of line Layer
Command: [(zsso
Command: Line
O world x84.853 y-23.265 20

Lines command

Line
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F2

Autocomplete, Left select command in list, or start typing and press ENTER

Command Options, select or type key

Circle Center, radius
2P
3P

F1 for help

CTRL + A = Erase All, Del
Shortcuts:
L = Lines
D = Delete
M = move
Z=Z7Zoom
ZE = Zoom extents
U =undo
O = Ortho on/off

Tools > Options — Aliases

ﬁ Rhino Options

» Annotation Styles

Document User Text

Grid

Hatch

Linetypes

Location

Mesh

Motes

Render

Units

Web Browser

Rhino Options
Advanced
Alerter
Aliases

v

v

Appearance
File Explarer
Files

v

General

Idle Processor
Keyboard
Licenses

Alias: Command macro:
AdvancedDisplay ! OptionsPage DisplayModes
Break ! DeleteSubCrv

C ' SelCrossing

COff ' CurvatureGraphoff
COn ' CurvatureGraph
DisplayAttrsiigr | _OptionsPage _DisplayModes
M ! _Move

Q ' Ortho

P ' Planar
PluglnManager ! _OptionsPage _Pluglns
POff ! PointsOff

POn ! _PointsOn

3 ' Snap

SelPolysurface ' SelPolysrf

u Undo

W ' Selwindow

z ' Zoom

ZE ' Zoom _Extents

ZEA ' Zoom _All _Extents

s ' Zoom Selected

Z5A ' Zoom _All_Selected
T ' Zoom Target
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To repeat last command: ENTER, SPACEBAR or right-click

List of commands that do not repeat: Tools > Options > General

ﬂ Rhino Options

> Annotation Styles
Document User Text
Grid
Hatch
Linetypes
Location
Mesh
Notes

> Render
Units.
Web Browser

Rhino Options
Advanced
Alerter
Aliases

> Appearance
File Explorer

> Files
General
Idle Pracessor
Keyboard
Licenses.

> Modeling Aids

> Mouse
Plug-ins

Right-click command window to view recent commands (Max 20 — Options: General)

The Interface

Most-recently-used commands pop-up menu

Limit list 20 E commands

Show these commands at the top of the menu:

Command Lists
Run these commands every time Rhino starts:

Never repeat these commands:
History
Undo
Delete

Undo

Max memory used (MB): 1024 El

Default surface isocurve density
18 show surface isocurves

Isocurve density: 1 E

Lesson01

Sidebar

Floating

Closing

Tools > Options — Toolbars
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-
ﬂ Rhino Options

> Annotation Styles File Edit
Document User Text Toolbars and Toolbar Groups
Grid
Hatch default
Linetypes 7 [ lines
Location & Olock
Mesh & O LookAbout
Notes 5
> Render & []Main1
Units ° [OMain2

Web Browser &7 [] Mass Properties

Updates and Statistics sfls
> View WA h ‘/4 m‘ (i

Docking

ﬂ Untitled - Rhino & Educational Lab L
File Edit View Curve Surface Su

Standard CPlanes SetView [

DeES8IT XD O

... Top |"

swoe

Double-click title

Standard toolbar

Tooltips: Left or right-mouse button
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The Interface

Rhino Options & ] Mesh Booleans
;::\::::ad & [] Mesh Creation
) 22 [] Mesh Tools
Aliases O Move
> A-ppearaﬂce & O Newin V8
F‘,:E Explorer = [ Object Snap
N
Z:nsera\ @ g Organic
\dle Processar % ] Planar Booleans
Keyboard B [ Plane
Licenses ¢ [JPoint
> Modeling Aids *y [ Point Edit
> Mouse & [ Polygon
Plug-ins @ [ Popup
Render Libraries 0 [] Properties
Rhino Render 4% O PushPull
RhinoScript =
Selection Menu koo ‘ﬂf\‘:jl‘@‘@; DJE‘ (9‘“'1#‘%‘ 94046404 Add

i
)

Properties

Help
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Rhino 8 Educational Lak
File Edit View Curve
Standard CPlanes !

D87 »
R e JBT,

"] Polyline
(™ Line Segments

9.852.
AN

Triangle => Cascading toolbar which you can float

Standard CPlanes Set View

D=E8TXxD0

Viewports

Activate, Resize, Maximize, Rename, Right-click for menu or click triangle
Maximize, then use viewport tabs to switch between viewports

View > Viewport Layouts

Object snaps

OSnap *
[CH. 4
v End
Near
Point
v Mid
Cen
Int
Perp
Tan
Quad
Knot
Vertex
Project

Disable

Perspective | Front Front Right <

Next point of polyline. Press Enter when done ( PersistentClose=No Mode=Line Helpers=No Length Undo
Next point of polyline. Press Enter when done ( PersistentClose=No Close Mode=Line Helpers=No Length
Command:‘

O world % -37.467 y-52632 z0 Millimeters . Default Grid Snap  Ortho  Planar  Osnap

If you floated the Filter panel, drag it back by the tab name not the .... To place it next to Osnap.
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v End
Near
Point
Mid
Cen
Int

Tan

PolySurfaces
Quad

SubDs

Knot Meshes
Vertex Annotations
Project Lights

Blocks
Control Points
Point Clouds
Hatches
Others

Sub-objects

Disable

The Status bar, hiding the side menus, the coordinate system, x,y,z ccordinates, units,
Panels: Properties, Layers, Display (curves, Grid)
Help + Auto-update

Window > Window Layouts > Save

Mouse Actions
Navigation:

Rotate View in Perspective views: Click and hold the right mouse button (RMB) and move the
mouse.

Pan View in Perspective views: Shift + RMB, then move the mouse.
Pan view in parallel views: RMB.

Zoom View: Scroll the mouse wheel up or down to zoom in or out.
Selection:

Select Object: Left-click on the object.

Select Multiple Objects: Hold down the SHIFT key while clicking on additional objects. Use CTRL to
deselect.

Select Objects in a Window: Drag a selection window (from left to right) around the objects you
want to select. Only objects completely enclosed by the window will be selected.

Select Objects in a Crossing Window: Drag a selection window (from right to left) around the objects
you want to select. Objects intersected or enclosed by the window will be selected.

Editing:

Move Object: Select the object, then click and drag with the left mouse button.
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View Manipulation:

Change Viewport: Click on one of the viewport tabs (Top, Perspective, Front, Right, etc.) at the top of
the Rhino window.

Perspective | Front Front Right <

3 curves added to selection.
4 curves added to selection.
Command:

Maximize Viewport: Double-click on a viewport tab to maximize it. Double-click again to restore.

Getting Started

Open the file Start.3dm

View > Viewport Layout > 4 Viewports
Status bar, units, Grid Snap on
Perspective view, Shaded

Render > Render

ﬂ Rhino Render on NVIDIA GeForce RTX 4070 - [Unnamed-02] = (=] X
File Edit View Render Help

NEHROSO0800@@® X

Tp—

$ Final Pass
T Post Effects

Denoise

[ cCurves

[ Surface edges and isocul
[JPoints and point clouds
] Dimensions and text

No selection.

(=]
Render ready 50 samples, duration Oh Om 1.63s Image: 1591 x 794 Zoom: 1:2 RGBA

Save the image

Close the Render window

Expertise Training Center (ETC) Page |8



Rhino 8 The Interface

Orbit with RMB
X-Ray

Ghosted
Rendered
Technical Artistic
Pen

Wireframe

Lesson01

Navigating

In Perspective view, SHIFT + RMB to pan

In other views, drag with RMB button to pan
Roll the wheel to zoon in and out

CTRL + RMB to zoom in and out

ZE ENTER to zoom Extent or View > Zoom > Zoom Extents

View > Zoom > Zoom Extents All

Move Objects
Gumball off, Drag

Grid snap on, drag => Moves on view grid

Grid settings, use Analyze > Distance to verify grid settings

Start dragging, tap ALT to copy (Don’t hold down the ALT key). The tap should quick to work.

Copy Objects
ESC
Transform > Copy

Select object, press ENTER to repeat copy
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Gumball

Gumball actions

Drag gumball arrows to Move the object.
Drag scale handles (squares) to Scale the object in
Drag arcs to rotate the object.

Click a control handle to enter a numeric value.
Hold the Shift key during Scale to force 3-D scale.

Gumball Controls

@ Axis plane indicator

(2 Free move origin

@ Menu location
Move arrows

@ Move X
@ Move Y
@ Move Z

Rotation arcs
® Rotate X
Rotate Y

@ Rotate Z
Scale handles

@ Scale X
@ Scale Y
@ Scale Z

@ extrude z

Gumball On, Grid snap off

The Interface

one direction.

Tap the Alt key after starting to drag to toggle copy mode.

Right-click Gumball > Settings, increase radius to 200

Sizes in pixels

Gumball radius: 200
Tip length: 50
Tip width: 13

Scale handle size: 10

Plane location: 100

Drag arrow to move

Click arrow to set distance

Expertise Training Center (ETC)
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To place the object on the origin, Snap on, Center, Move, to 0,0

Scale using handles

Move handles Double click

Double-click handle to stretch it

Click inside handle to enter a scale value, 2 => two times
Use Analyze > Distance with snap to check values

SHIFT scale to scale in all directions

Start moving, tap ALT to copy

Drag arcs to rotate, better in parallel views

Click arc to enter degree

RGB = XYZ

Rotate the box
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Click menu handle to align Gumball with World axis

Relocate Gumball

Reset Gumball

AutoReset Gumball
Gumball On

Gumball Off

Align to CPlane

Align to Object

Align to World

Align to View

Snappy Dragging
Smooth Dragging

Merge faces after extrude
Rotate View Around Gumball
Drag Strength

Settings...

Use the Axis plane indicator to move or scale in the indicated plane. Rotate the view to display other
planes.

Use menu to relocate Gumball and Reset

Parallel Vs. Perspective Projection

Perspective view (One point perspective)
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isometric projection perspective projection

Right-click Title > Viewport Properties
Change Projection

2-Point Perspective
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Pan and Zoom

Use Arrow keys on keyboard to rotate view

Use CTRL + arrow keys to pan

Page up/ Page down to zoom in and out
Home to undo view change

End to redo view change

View > Set view > Plan

View > Set view > Perspective

View > Zoom > Extents, ...

Right-click view name > Set View > ...

Display Options

Open Camera.3dm

In Perspective view experiment with arrow keys.

Right-click Top view title > Viewport Layout > Split Horizontal
Split the Front and right view vertical

Right-click view title > Set view,...

View >Zoom >...

Double-click view title to maximize/restore

View > Viewport layout > Float
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Pyseecie Top k| o 18
Close viewport

Resize viewport

View > Viewport layout > 4 viewports

Hide left sidebar — Button in the bottom left corner

Hide right side bar

Start Drawing

Open the file Practice with Lines.3dm

All line and polylines in rhino are curved geometry

Use help to understand command options and menu location
Curve > Line >...

Curve > Polyline > ...

Edit > Explode

Edit > Join

Expertise Training Center (ETC)

Page |15



Rhino 8 The Interface

Curve > Free-Form > Control points

Line — Bothsides

BothSides Draws the object on both sides of the start point, creating the object twice as long as you indicate.

Q

of

0
Line — FourPoint
FourPoint Draws the line using two points to establish direction and two points to establish length.

1
3
\:},
2
N

Save As

Open the file ring and practice the above
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